Sie sind nicht angemeldet.

Noch kein Mitglied? Um alle Funktionen des Forums nutzen zu können, sollten Sie sich registrieren. Heute noch, bevor ein Anderer schneller ist!

1

Montag, 6. August 2018, 20:57

Klimaanlage ohne Funktion

Hallo
ich habe einen Sonata EF Bj 2002 in derPflege,bei diesem ist die Klima ohne Funktion. Die Anlage ist frisch befüllt und der Drucksensor ist

Neu gemacht worden in einer freien Werkstatt aber ohne Erfolg. Dann zu Hyndai zum Fehler auslesen, laut Hyndai ist das klimasteuergerät
defekt. Weiß jemand wo das sitzt? Als Bedienteil ist eines mit Knöpfen verbaut ohne Drehregler,( was allerdings auch wie ein Steuergerät
aussieht).Ich habe noch die Sicherungen kontrolliert und die Relais alles soweit in Ordnung. Am Relais vom Klimakompressor kommt

allerdings keine Masse an am Braunorangenen Kabel,(weiß jemand wo dieses herkommt zum Bedienteil konnte ich es nicht durchmessen).
Wenn ich die Lüfter ansteuere und den Kompressor dann kühlt die Anlage.Hat vielleicht jemand ein Schaltplan eine Idee oder eine andere

Meinung als Hyndai ? Laut Hyndai gibt es kein Steuergerät und im Netz gibt es gebrauchte für 150€ zur Fehlerfeststellung recht teuer.
Vielen Dank für qualifizierte Antworten


Neko

Opa

Beiträge: 1 918

Wohnort: Recklinghausen

Auto: Galloper 2.5TCI

Vorname: Bernd

  • Nachricht senden

2

Montag, 6. August 2018, 22:13

Hallo

Beim Sonata EF wird das AC Komporessorrelais über Masse vom Motorsteuergerät (ECU) geschaltet.
Die Nummer des entsprechenden Pins am Motorsteuergerät ist unterschiedlich für 4 und 6 Zylinder,MT oder AT Getriebe, mit /ohne Wegfahrsperre,also weitere Infos gefragt.
Druckschalter, diverse Sensoren und Klimabedienteil sind mit dem Motorsteuergerät verbunden.
Die widersprüchlichen Aussagen "Klimasteuergerät defekt" und "Es gibt kein Steuergerät", sind durch die hohen Sommertemeraturen hervorgerufene Lustlosigkeit zu erklären.
Man will sich halt keinen Kopf darüber machen.
Es gibt aber eine Selbstdiagnosefunktion über das Display am Bedienteil.Zwei Stellen der Temperaturanzeige zeigen den Fehlercode.
Zündung an, Ventilatorschalter mehr wie 4X innerhalb von 2 Sekunden drücken während die "AUTO" Taste gedrückt ist.
Das Display blinkt dann 3X für eine halbe Sekunde und die Selbstdiagnose beginnt.Wenn es öfter wie 3X blinkt sind mehrere Fehlecodes gespeichert, mit der "AUTO" Taste kommt man dann zum nächsten Code .
Mit der "OFF" Taste beendet man den Selbstdiagnosemodus.

Gruss Bernd

3

Dienstag, 7. August 2018, 10:56

Vielen Dank Bernd
die Selbstdiagnose über das Display funktioniert nicht auch nicht mit anderen Tastenkombis auch wenn ich ein Fehler setze, es ist kein

Auslesen möglich. Das Auto ist ein 6 Zyl. mit AT-Getriebe. Wenn die bei Hyndai vom Klimasteuergerät sprechen meinen die das Bedienteil
oder ist des Steuergerät noch woanders versteckt? Ich hänge noch ein Bild vom Display mit ran.
»Heiko K« hat folgendes Bild angehängt:
  • Display.gif

Neko

Opa

Beiträge: 1 918

Wohnort: Recklinghausen

Auto: Galloper 2.5TCI

Vorname: Bernd

  • Nachricht senden

4

Dienstag, 7. August 2018, 11:51

Hallo Heiko

Die gesteuerte Masse vom Kompressorrelais geht zu Pin 29 des Motorsteuergeräts (ECU).
Meine Informationen sind von 1999, das abgebildete Bedienteil hat auch ein rundlicheres Design.
Es hat ab 2001 ein andere Version gegeben.
Was funktioniert über das Bedienteil denn überhaupt noch, Gebläsedrehzahl u.s.w ?
Wenn der Selbstdiagnosemodus nicht funktioniert ist es vielleicht defekt und man sollte ein anderes gebrauchtes Bedienteil ausprobieren.

Gruss Bernd

5

Dienstag, 7. August 2018, 16:51

Vielen Dank

für die Antwort,dann bestelle ich erst einmal ein Gebrauchtes und melde mich dann zurück. :)

6

Samstag, 11. August 2018, 18:09

Hallo

habe Heute ein anderes Display eingebaut, Ohne bessere Funktion. Bei der weiteren Prüfung heut habe ich festgestellt das mit betätigen vom

Klimaknopf die Motordrehzahl erhöht wird (auslesen über Display immer noch nicht möglich).Darauf habe ich noch mal mein Tester angeschlossen
und bin in die Motorsteuerung Klima geht damit leider auch noch nicht. Ich konnte auslesen das der Klimaknopf betätigt wird aber das Relais nicht angesteuert wird. Im Stellgliedtest habe ich dann das Klimarelais angesteuert dieses schaltet auch bis zur Magnetkupplung.Die Lüfter ließen

sich beide in hoher Geschwindigkeit ansteuern bei kleiner Geschwindigkeit drehte nur der linke und das Relais mit dem weißen Strich wurde
angetaktet über Masse hatte aber kein Strom auf 86 somit konnte es nicht schalten. beim bestromen auf 86 ging alles eigenartige Wege.
Hat vielleicht jemand ein Schaltplanauszug oder eine Idee? :mauer: :mauer:
»Heiko K« hat folgende Bilder angehängt:
  • 20180811_114837-1.jpg
  • 20180811_115018-1.jpg

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »Heiko K« (11. August 2018, 18:15)


Neko

Opa

Beiträge: 1 918

Wohnort: Recklinghausen

Auto: Galloper 2.5TCI

Vorname: Bernd

  • Nachricht senden

7

Samstag, 11. August 2018, 18:33

Hallo Heiko

Du hast eine persönliche nachricht.

Grus Bernd

8

Dienstag, 14. August 2018, 21:20

Hallo Leute

habe noch keinen Fehler gefunden.
Hat vielleicht jemand im Raum Potsdam einen geeigneten Tester?

Ähnliche Themen